The Elder Scrolls Forums

TES Construction Set and Plugins >> General TES Construction Set

Pages: 1 | 2 | (show all)
EllaTrue
Novice

Reged: 06/09/04
Posts: 21
Crazy Dialogue Error
      #2675596 - 06/09/04 02:50 PM

Is it possible for the dialogue functions to break? One of the topics in my plugin isn't working anymore (i.e. won't turn blue so you can click it), and in another instance the stuff I entered into the results field simply isn't working. I checked and re-checked everything, and as far as I can tell it should be working.

Is there any way to fix this? Am I overlooking something?

Post Extras: Print Post   Remind Me!   Notify Moderator  
Szazmyrr3
Curate

Reged: 07/07/03
Posts: 841
Loc: Tucson, AZ
Re: Crazy Dialogue Error [Re: EllaTrue]
      #2675745 - 06/09/04 03:50 PM

As for the first part of your problem, make sure you spelled the topic exactly right. For the second part, could you be more specific, whta exactly did you enter in the results field? It has to be a one-line command (no "if" statements).

--------------------
EX-XBOXER

My Site

My Mod Site

Fallaran Mod; shot-of-the-day Updated 08/24/04 20:55

Post Extras: Print Post   Remind Me!   Notify Moderator  
Klinn
Diviner

Reged: 11/19/02
Posts: 2319
Re: Crazy Dialogue Error [Re: EllaTrue]
      #2676259 - 06/09/04 06:23 PM

Well anything is possible with the Editor , but the dialogue functions are probably not broken. Usually a topic does not show up as a blue link because at the time the NPC speaks the dialogue, there are filter conditions on the topic which prevent the player from knowing about it.

I ran into something like that - my NPC's greeting included the topic word, and in the Results box of the greeting a Journal entry was given. The topic had a condition that the player must have received the Journal entry. So at the moment the NPC gave the greeting (before the Results box commands had been executed) the player didn't have the Journal entry yet, so the topic didn't show up in blue.

So check the conditions on the topic carefully to see if something like that is preventing it from appearing.

As for commands in the Results box, there are certain restrictions but generally they work OK. Best thing would be for you to cut'n'paste them into a post here. Maybe one of us can spot a typo or something.

...Klinn


Post Extras: Print Post   Remind Me!   Notify Moderator  
Archived User Account

Re: Crazy Dialogue Error [Re: EllaTrue]
      #2676897 - 06/09/04 09:52 PM

Quote:


Is it possible for the dialogue functions to break? One of the topics in my plugin isn't working anymore (i.e. won't turn blue so you can click it)





A couple more possibilities:

1. I have read that if another mod adds a topic that's the same as one your mod adds, then your topic may not show up in blue. If this is the problem, the fix is using AddTopic.

I don't have personal experience with this problem. Emma posted an explanation in the Comprehensive Dialogue thread.

I've quoted her below; here's a link to the thread (which has a lot of useful tips and info about dialogue): http://www.elderscrolls.com/ubbthreads/showflat.php?Cat=&Number=1227862

----------------------------------------------------------------------------

Emma said:

If a newer plugin has the same new topics as your plugin, the newer plugin will "overwrite" your plugin, and the topic in your plugin will never be highlighted and never show up ingame.

In order to avoid this, you should always add an AddTopic command when using a new topic for the first time.

I.e. say that you are going to use the topic "together".

Dialog line: "We really should stick together"

Resultbox: AddTopic "together"

Now, your new topic will always show up. If overwritten by another, newer plugin, it will not be highlighted anymore, but it will still show up among the topics.
Your plugin will be playable but less intiutive.

----------------------------------------------------------------------------

2. An NPC can only talk about a topic if he meets the conditions for one of the responses to that topic. If he doesn't qualify for any of the responses, he can't talk about it (nothing to say) and it won't be highlighted or listed in his topic list.

Check that topic and its responses to make sure the NPC meets the conditions to use at least one response for that topic. Something may have changed during game play that causes none of the responses to qualify, you may have changed something in the mod that changed the conditions for the response(s), etc..

Post Extras: Print Post   Remind Me!   Notify Moderator  
EllaTrue
Novice

Reged: 06/09/04
Posts: 21
Re: Crazy Dialogue Error [Re: Szazmyrr3]
      #2677506 - 06/10/04 02:01 AM

Well, as far as the dialogue filters go, it should be working, although I'll probably check it a third time just in case something magically happens. There might be something wrong with what I wrote in the results field, let me know if you see anything:

Player->AddItem, "_ech_note_kidnap" 1
Journal "AM_revenge" 50

The topic is "clear Anton's name," so I doubt it could conflict with another mod.

[panics]

Post Extras: Print Post   Remind Me!   Notify Moderator  
Archived User Account

Re: Crazy Dialogue Error [Re: EllaTrue]
      #2677591 - 06/10/04 02:53 AM

Quote:


Well, as far as the dialogue filters go, it should be working, although I'll probably check it a third time just in case something magically happens. There might be something wrong with what I wrote in the results field, let me know if you see anything:

Player->AddItem, "_ech_note_kidnap" 1
Journal "AM_revenge" 50

The topic is "clear Anton's name," so I doubt it could conflict with another mod.

[panics]





For figuring out the problem with the topic not highlighting: make a test copy of your mod, then try the following (work with the test .esp file; don't mess with the original; might be useful to backup the original somewhere).

1. In the test .esp file, create a copy of the response the NPC should have to that topic (right click and choose copy).

2. For that copy, clear all speaker conditions and save the test .esp. Go into the game with the test .esp (instead of the original .esp) and see if the topic shows up highlighted.

3. If it does, then go back and reset the speaker conditions one at a time until you figure out which one is causing the problem.

4. If it still doesn't show up, proofread very very carefully for typos, etc.

Note: don't save the game with the test .esp file loaded.

----------------------------------------------------------------------------
For the results box not working, here's what I noticed...

Should be another comma in the first line:

Player->AddItem, "_ech_note_kidnap", 1

Also:

If this was working before, this probably isn't your problem, but just for future reference: using leading underscores ("_ech_note_kidnap") in object IDs, variable names, etc. can have unpredictable results: sometimes it works fine, sometimes it causes errors. I recommend not using them; much safer.


Second line is missing two commas:

Journal, "AM_revenge", 50

Don't know if the missing commas are the problem with the results box not working; I always put them in.

Post Extras: Print Post   Remind Me!   Notify Moderator  
Emma
Disciple

Reged: 10/08/02
Posts: 1547
Loc: Sweden
Re: Crazy Dialogue Error [Re: ]
      #2677888 - 06/10/04 05:58 AM

Quote:

Second line is missing two commas:

Journal, "AM_revenge", 50

Don't know if the missing commas are the problem with the results box not working; I always put them in.




I don't think this is a problem; I never use "" or , in such lines and I have never experienced any problems.
But, the _naming of objects is a known source to problems.

(BTW, really good to see you around, DinkumThinkum )

--------------------
Emma's Morrowind Site
My mods - TheLys
Gamer's Roam
WIP Head packs





Post Extras: Print Post   Remind Me!   Notify Moderator  
Archived User Account

Re: Crazy Dialogue Error [Re: Emma]
      #2677928 - 06/10/04 06:26 AM

Quote:


I don't think this is a problem; I never use "" or , in such lines and I have never experienced any problems.
But, the _naming of objects is a known source to problems.

(BTW, really good to see you around, DinkumThinkum )





I really don't know if the commas make any difference, but the devs did it that way in the examples I've looked at from the game, and SFD shows them that way. So I always try to put them in, just in case...

I found out about those _leading underscores the hard way. The problem is mentioned in Scripting for Dummies now, but I don't think it's very well known yet.

And it's good to see you around, still modding and still helping out, Emma!

Post Extras: Print Post   Remind Me!   Notify Moderator  
EllaTrue
Novice

Reged: 06/09/04
Posts: 21
Re: Crazy Dialogue Error [Re: ]
      #2682706 - 06/11/04 06:03 PM

Can naming the NPC itself with an underscore (in the id) cause a problem?

I changed an = to a >= and that seemed to solve the problem with the topic not showing, on the chance that there needed to be dialogue for the topic with every following journal index (before the last)- thinking that might have screwed it up somehow. At any rate, it works now, for whatever reason.

However, the results field thing still won't work. I renamed the note without the leading underscore, and tried changing the syntax with the commas, but still no luck. Neither the item nor the journal entry appeared.

____
Okay, latest Update:
I tried working around it by creating a new topic for the character, to see if that would work with the results. It didn't! When I tried to add the note with the console, I got an error message.
All the other quests worked fine, and the results field worked well for the rewards with different NPC's.

Edited by EllaTrue (06/11/04 09:12 PM)

Post Extras: Print Post   Remind Me!   Notify Moderator  
Archived User Account

Re: Crazy Dialogue Error [Re: EllaTrue]
      #2683462 - 06/11/04 09:51 PM

Quote:


Can naming the NPC itself with an underscore (in the id) cause a problem?





_Leading _underscores should be avoided; ones in_the_middle don't cause any problems that I've ever heard of.

I confirmed that the leading underscores definitely caused problems with Object IDs and with variable names. After that, I just stopped using them for anything in the Construction Set. I didn't take the time to specifically test Journal entries, etc.

Quote:


However, the results field thing still won't work. I renamed the note without the leading underscore, and tried changing the syntax with the commas, but still no luck. Neither the item nor the journal entry appeared.

____
Okay, latest Update:
I tried working around it by creating a new topic for the character, to see if that would work with the results. It didn't! When I tried to add the note with the console, I got an error message.
All the other quests worked fine, and the results field worked well for the rewards with different NPC's.





If you're getting an error when you try to add the journal entry from the console, most likely either your syntax is wrong or you have a typo in the name of the journal.

Double check (in the editor Dialogue window) that the journal topic "AM_revenge" actually exists and that it's spelled exactly the same in the results box as it is in the list of journal topics.

----------------------------------------------------------------------------

To see what I'm talking about:

1. Try this from the console (in the game):

----------------------------------------------------------------------------

Journal, "11111 test journal", 10

----------------------------------------------------------------------------

That should give you the usual 'Your journal has been updated' message (on the main screen), and you should see a 'This is a test' entry (or similar wording) in your journal.

2. Now, from the console again, try the following line:

----------------------------------------------------------------------------

Journal, "xyx", 10

----------------------------------------------------------------------------

That should give you an error message; in the middle of the error message it should say something about 'dialogue topic xyx not found', or something like that.

Is that the same error message you're seeing? Because that's the error message you get when you try to add a journal entry for a journal topic that doesn't exist.

(11111 test journal" is an actual journal topic in the game (for testing), but there's no such journal as "xyz".)

Post Extras: Print Post   Remind Me!   Notify Moderator  
EllaTrue
Novice

Reged: 06/09/04
Posts: 21
Re: Crazy Dialogue Error [Re: Emma]
      #2687098 - 06/13/04 12:48 AM

Hmm...

I kind of gave up and tried to work around the problem, by placing the note on a table, attaching a script to it that would update the journal and having the NPC direct the player to pick it up.

Everything worked fine, until later in the quest you have to talk to the same NPC again. Again, the results field didn't function, and the journal wouldn't update. So I think the problem is the NPC itself, somehow.

Post Extras: Print Post   Remind Me!   Notify Moderator  
EllaTrue
Novice

Reged: 06/09/04
Posts: 21
Re: Crazy Dialogue Error [Re: Emma]
      #2877305 - 08/01/04 11:09 PM

Thanks a lot for your help (and you too, Dinkum). It turns out the problem was the underscore- the NPC had an underscore in his ID, and once I got rid of it everything worked out fine.

Post Extras: Print Post   Remind Me!   Notify Moderator  
Archived User Account

Re: Crazy Dialogue Error [Re: EllaTrue]
      #2877533 - 08/02/04 12:11 AM

Quote:


Thanks a lot for your help (and you too, Dinkum). It turns out the problem was the underscore- the NPC had an underscore in his ID, and once I got rid of it everything worked out fine.





Glad you got it working!

Was it a _leading underscore, or an in_the_middle underscore that caused the problem?

Leading underscores have been confirmed as a problem before, but I've never heard of underscores causing problems in the middle of something. The original game has underscores in the middle of large numbers of Object IDs, and many mods use those too; it's just the ones at the beginning of Object IDs that are known to cause problems.

Post Extras: Print Post   Remind Me!   Notify Moderator  
EllaTrue
Novice

Reged: 06/09/04
Posts: 21
Re: Crazy Dialogue Error [Re: ]
      #2880356 - 08/02/04 07:23 PM

it was in the front

also, thanks again to everybody who helped, it's appreciated

Post Extras: Print Post   Remind Me!   Notify Moderator  
Archived User Account

Re: Crazy Dialogue Error [Re: EllaTrue]
      #2880384 - 08/02/04 07:31 PM

Quote:


it was an in the middle type thing





That's definitely weird, because there are tons of Object ID's, etc. in the game and in mods that use underscores in the middle without problems.

Thanks for the feedback!

Post Extras: Print Post   Remind Me!   Notify Moderator  
Pages: 1 | 2 | (show all)


Extra information
1 registered and 4 anonymous users are browsing this forum.

Moderator:  Umrahel, Freddo, Pete, Hungry Donner, Attrebus, Miltiades, tegger 

Print Thread

Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Thread views: 180

Rate this thread
 
Jump to

The Elder Scrolls Homepage

*
UBB.threads™ 6.3

Click for Privacy Statement 2003 Bethesda Softworks LLC, a ZeniMax Media company. All Rights Reserved.
PRIVACY POLICY | TERMS & CONDITIONS | LEGAL INFORMATION | CONTACT US